$re = '/^(\d*)[.,](\d+)$/m';
$str = '15
12.3
56,75';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);