$re = '/^(?<name>\w*)/m';
$str = 'james buildingA
jack buildingB firstfloor';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);