re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[~!@#$%^&*])[a-zA-Z][a-zA-Z\d]*[~!@#$%^&*?<>]*$/m
str = 'abAA1#
a123b#
a123B#$$
123aA##
#abcABC123#
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end