# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?im)^(?<c1>\"?)\w+(?:[\W&&[^@]]?)\w+\k<c1>@(?:\[?(?:\d{3}\.?){0,4}\]?|(?:[\w&&[^\d]]+[\.\-]?)*(?<=\.\w{2,6}))$"
test_str = ("List of Valid Email Addresses\n\n"
"email@example.com\n"
"firstname.lastname@example.com\n"
"email@subdomain.example.com\n"
"firstname+lastname@example.com\n"
"email@123.123.123.123\n"
"email@[123.123.123.123]\n"
"\"email\"@example.com\n"
"1234567890@example.com\n"
"email@example-one.com\n"
"_______@example.com\n"
"email@example.name\n"
"email@example.museum\n"
"email@example.co.jp\n"
"firstname-lastname@example.com\n\n\n\n"
"List of Strange Valid Email Addresses\n\n"
"much.”more\\ unusual”@example.com\n"
"very.unusual.”@”.unusual.com@example.com\n"
"very.”(),:;<>[]”.VERY.”very@\\\\ \"very”.unusual@strange.example.com\n\n\n\n"
"List of Invalid Email Addresses\n\n"
"plainaddress\n"
"#@%^%#$@#$@#.com\n"
"@example.com\n"
"Joe Smith <email@example.com>\n"
"email.example.com\n"
"email@example@example.com\n"
".email@example.com\n"
"email.@example.com\n"
"email..email@example.com\n"
"あいうえお@example.com\n"
"email@example.com (Joe Smith)\n"
"email@example\n"
"email@-example.com\n"
"email@example.web\n"
"email@111.222.333.44444\n"
"email@example..com\n"
"Abc..123@example.com\n\n\n\n"
"List of Strange Invalid Email Addresses\n\n"
"”(),:;<>[\\]@example.com\n"
"just”not”right@example.com\n"
"this\\ is\"really\"not\\allowed@example.com")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.