re = /https?:\/\/[^\s]+(?<![,.)\]])/m
str = 'This is https://cache-elastic-pandora.ecn.cl/emol/noticia/_search?q=publicada:true+AND+ultimoMinuto:true+AND+seccion:*+AND+temas.id:*&sort=fechaModificacion:desc&size=15&from=45, hero and then goes (http://google.com) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end