import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w-]+?)=(\".*?\"|\\S+)";
final String string = "appName=XXX clientIp=X.X.X timestamp=\"2017-06-05T13:22:12-07:00\" request=\"POST /forward HTTP/1.1\" statusCode=204 bytesOut=1167 totalTime=0.062 bytesIn=1289 sourceHost=XXXX connId=49936598 connReqs=9 upInstance=XXX:104:XXX-XXX:8664:17F34 upConnectSec=0.052 upAddr=\"XX.XX.XX:123\" upHost=\"vcv08it-cvcv2801:8464\" upHdrTimeSec=0.058 upRespTimeSec=0.058 pid=32561 upStatusCode=204 message=\"Access Log\" corrKey=GMIFCDIKRZR2T4VZQXJA2IT6 upCached=- length=0 partition=XXX location=\"= /v1/tXXXX\" xff=\"XX.XX.XX.XX\" referer=\"-\" user-agent=\"Apache-HttpAsyncClient/4.1.1 (Java/1.8.0_131)\\\" rateLimitCurrentValues=\"--\" rateLimitTimeMs=\\\"-:-\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}