re = /^(?!(\d)\1{2}-(\d)\1{1}-(\d)\1{3})$|^(?!(\d)\1{8})$/m
str = '888888888
123456789
888-88-8888
123-45-6789
111-22-3333
333-33-3333'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end