const regex = new RegExp('("FILENAME" "([^\\/:*?"<>|]+)")', 'gm')
const str = `130 (UID 1245 BODYSTRUCTURE ((("TEXT" "PLAIN" ("CHARSET" "UTF-8") NIL NIL "QUOTED-PRINTABLE" 847 17 NIL NIL NIL)("TEXT" "HTML" ("CHARSET" "UTF-8") NIL NIL "QUOTED-PRINTABLE" 2009 41 NIL NIL NIL) "ALTERNATIVE" ("BOUNDARY" "000000000000929e4505d59042b1") NIL NIL)("IMAGE" "JPEG" ("NAME" "BS_01.jpg") "<f_kyetquhw1>" NIL "BASE64" 280364 NIL ("ATTACHMENT" ("FILENAME" "BS_(01)_a.jpg")) NIL)("IMAGE" "PNG" ("NAME" "payroll_check_top_format.png") "<f_kyetquio3>" NIL "BASE64" 498210 NIL ("ATTACHMENT" ("FILENAME" "payroll check top format.png")) NIL)("IMAGE" "JPEG" ("NAME" "missouri_dl_3e_1300x884.jpg") "<f_kyetquia2>" NIL "BASE64" 1014040 NIL ("ATTACHMENT" ("FILENAME" "missouri_dl_3e_1300x884.jpg")) NIL)("IMAGE" "JPEG" ("NAME" "1040-1-1_N.jpg") "<f_kyetquhj0>" NIL "BASE64" 4272596 NIL ("ATTACHMENT" ("FILENAME" "1040-1-1_N.jpg")) NIL) "MIXED" ("BOUNDARY" "000000000000929e4705d59042b3") NIL NIL))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}