re = /^\w+(\.\w+)*@\w+(\.\w+)+|(\w+(\s\w+)*)|[a-z0-9]+$/m
str = 'test-def.ghi@de.jkl.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end