using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(.*看.*|.*听.*)).*斗地主(?!.*电影|.*电视剧|.*音乐|.*歌|.*综艺|.*动漫|.*动画片).*";
string input = @"你爸爸是谁";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}