#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<query_date>\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}Z UTC) \[ (db=(?P<db>\w+) )?LOG:(?P<query_text>[\w|\W]*?;)"
Local $sString = "'2021-06-23T08:02:08Z UTC [ db=dev LOG: BEGIN;" & @CRLF & _
"'2021-06-23T08:02:08Z UTC [ db=dev LOG: SET datestyle TO ISO;" & @CRLF & _
"'2021-06-23T08:02:08Z UTC [ db=dev LOG: SET TRANSACTION READ ONLY;" & @CRLF & _
"'2021-06-23T08:02:08Z UTC [ db=dev LOG: SET STATEMENT_TIMEOUT" & @CRLF & _
" TO 300000;" & @CRLF & _
"'2021-06-23T08:02:08Z UTC [ LOG: /* hash: 8d9692aa66628f2ea5b0b9de8e4ea59b */" & @CRLF & _
"" & @CRLF & _
"SELECT action," & @CRLF & _
" status," & @CRLF & _
" COUNT(*) AS num_req" & @CRLF & _
"FROM stl_datashare_changes_consumer" & @CRLF & _
"WHERE actiontime > getdate() - INTERVAL '1 day'" & @CRLF & _
"GROUP BY 1,2;" & @CRLF & _
"'2021-06-23T08:02:08Z UTC [ LOG: SELECT pg_catalog.stll_datashare_changes_consumer.action AS action, pg_catalog.stll_datashare_changes_consumer.status AS status, COUNT(*) AS num_req FROM pg_catalog.stll_datashare_changes_consumer WHERE pg_catalog.stll_datashare_changes_consumer.actiontime > getdate() - interval '1 day'::Interval GROUP BY 1, 2;" & @CRLF & _
"'2021-06-23T08:02:08Z UTC [ LOG: COMMIT;" & @CRLF & _
"'2021-06-23T08:02:08Z UTC [ LOG: SET query_group to ''" & @CRLF & _
"'2021-06-23T08:02:22Z UTC [ LOG: SELECT 1" & @CRLF & _
"'2021-06-23T08:02:30Z UTC [ LOG: /* hash: 64f5dca78e917617f51632257854cb2f */" & @CRLF & _
"WITH per_commit_info AS" & @CRLF & _
"(" & @CRLF & _
" SELECT date_trunc('day', startwork) AS day," & @CRLF & _
" c.xid," & @CRLF & _
" SUM(num_metadata_blocks_retained) AS sum_retained," & @CRLF & _
" SUM(total_metadata_blocks) AS sum_total," & @CRLF & _
" AVG(num_metadata_blocks_retained) AS avg_retained," & @CRLF & _
" AVG(total_metadata_blocks) AS avg_total" & @CRLF & _
" FROM stl_commit_stats c," & @CRLF & _
" stl_commit_internal_stats i" & @CRLF & _
" WHERE c.xid = i.xid" & @CRLF & _
" < ...even more sql >;" & @CRLF & _
"'2021-06-23T08:02:30Z UTC [ LOG: SELECT per_commit_info.day AS day, COUNT(*) AS commits," & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")