using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ISA\*([^I]*(?:I(?!SA\*)[^I]*)*)";
string input = @"ISA*lots**of~other~data**with~~no terminating **pattern~ISA*lots**of~other~data**with~~no terminating **pattern~ISA*lots**of~other~data**with~~no terminating **pattern~ISA*lots**of~other~data**with~~no terminating **pattern~";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}