re = /^(?:rm -r?f?|(?:cp|mv))\b.*?\s\/((?:etc|boot|dev|lib(?:64)?|misc|mnt|net|opt|root|sbin|srv|sys|usr|var|bin)(\s|$|\/)|home(\s|$|[\/]+(?![^\/]+[\/+])))/
str = 'rm -rf /public_html/ /home/dfd/fd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end