$re = '/^\S*$/m';
$str = 'String123/test
String123/ test
String 123/test
String123/test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);