$re = '/(\w+\.\w+)$/m';
$str = 'example1.com
sub1.example1.com
sub-2.sub1.example1.com
suB3.sub-2.sub1.domain2.test
foo.domain2.test
sub.foo.domain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);