import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^@]{1}|^)(@[a-zA-z\\d]+)";
final String string = "@test1 стоп, не так все\n"
+ "@test1 не знаю даже @test1 тест@test1привет @@test1р\n"
+ "Привет, ребят @test2 как дела? @test1 @test2@test1\n"
+ "@test1п";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}