$re = '/^(\d+) (\p{Han}+)$/m';
$str = '023754 王哈哈';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);