# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Card number:\s(\d+\*+\d+)(?:(?!Card number:).)*?ID:\s*(\d*)(?:(?:(?!Card number:).)*?Total cash dispensed:\s*([a-zA-Z0-9]+)\s+([a-zA-Z0-9]+))?"
test_str = ("Card number: 99280*********8823, SEQ: 182\n"
"Current session ID: 182\n"
"21/01/2021 08:46:49 : Selected language : French\n"
"21/01/2021 08:46:49 : Chip application : NO Active \n"
" 21/01/2021 09:53:03 : Returned code : 0\n"
" 21/01/2021 09:53:03 : Pin entered\n"
" 21/01/2021 09:53:09 : Transaction selected: FastCash 40000 on ATM: Y6154514\n"
" 21/01/2021 09:53:10 : Returned code : 0\n"
"21/01/2021 09:53:13 : FastCash Authorization requested\n"
"!XXXXXXXXXXXXXXX3947#20210121065319#686817#0001969C0007469460900002969C000740946090#\n"
"21/01/2021 09:53:14 : FastCash Authorized\n"
"Returned code : 0, STAN: 686817\n"
"21/01/2021 09:53:27 : Cash dispensed\n"
"21/01/2021 09:53:28 : Card ejected\n"
"21/01/2021 09:53:29 : Card taken\n"
"21/01/2021 09:53:32 : Dispense details:\n"
"->cass 1: 0 x 5000 MGA, cass 2: 4 x 10000 MGA\n"
"->cass 3: 0 x 10000 MGA, cass 4: 0 x 20000 MGA\n"
"------->Total cash dispensed: 40000 MGA\n"
"21/01/2021 09:53:32 : Cash presented\n"
"21/01/2021 09:53:32 : Waiting for cash to be taken\n"
"21/01/2021 09:53:33 : Cash taken\n"
"21/01/2021 09:53:39 : Transaction completed\n"
" 21/01/2021 09:53:41 : Session terminated\n"
" Card number: 6700*********8823, SEQ: 177\n"
"Current session ID: 177\n"
"21/01/2021 10:04:06 : Selected language : French\n"
"21/01/2021 10:04:06 : Chip application : A0000000031010\n"
" 21/01/2021 10:04:53 : Returned code : 0\n"
" 21/01/2021 10:04:54 : Pin entered\n"
" 21/01/2021 10:05:03 : Transaction selected: BalanceInquiry on ATM: Y892614\n"
" 21/01/2021 10:05:04 : Returned code : 0\n"
"21/01/2021 10:05:09 : BalanceInquiry Authorization requested\n"
"!XXXXXXXXXXXX8727#20210121070516#686824\n"
" 21/01/2021 10:05:10 : BalanceInquiry Authorized \n"
" Returned code : 0, STAN: 686824\n"
"21/01/2021 10:05:11 : Chip Authorization approved\n"
"21/01/2021 10:05:18 : Transaction completed\n"
" 21/01/2021 10:05:38 : Transaction selected: Statement on ATM: Y892614\n"
"21/01/2021 10:05:43 : Statement Authorization requested\n"
"!XXXXXXXXXXXX8727#20210121070550#686825#\n"
"21/01/2021 10:05:44 : Statement Authorized\n"
"Returned code : 0, Auth: 686825\n"
"21/01/2021 10:05:45 : Chip authorization declined\n"
" 21/01/2021 10:06:00 : Card ejected\n"
" 21/01/2021 10:06:01 : Card taken\n"
" 21/01/2021 10:06:03 : Session terminated\n"
" Card number: 99280*********8823, SEQ: 182\n"
"Current session ID: 182\n"
"21/01/2021 08:46:49 : Selected language : French\n"
"21/01/2021 08:46:49 : Chip application : NO Active \n"
" 21/01/2021 09:53:03 : Returned code : 0\n"
" 21/01/2021 09:53:03 : Pin entered\n"
" 21/01/2021 09:53:09 : Transaction selected: FastCash 40000 on ATM: Y6154514\n"
" 21/01/2021 09:53:10 : Returned code : 0\n"
"21/01/2021 09:53:13 : FastCash Authorization requested\n"
"!XXXXXXXXXXXXXXX3947#20210121065319#686817#0001969C0007469460900002969C000740946090#\n"
"21/01/2021 09:53:14 : FastCash Authorized\n"
"Returned code : 0, STAN: 686817\n"
"21/01/2021 09:53:27 : Cash dispensed\n"
"21/01/2021 09:53:28 : Card ejected\n"
"21/01/2021 09:53:29 : Card taken\n"
"21/01/2021 09:53:32 : Dispense details:\n"
"->cass 1: 0 x 5000 MGA, cass 2: 4 x 10000 MGA\n"
"->cass 3: 0 x 10000 MGA, cass 4: 0 x 20000 MGA\n"
"------->Total cash dispensed: 40000 MGA\n"
"21/01/2021 09:53:32 : Cash presented\n"
"21/01/2021 09:53:32 : Waiting for cash to be taken\n"
"21/01/2021 09:53:33 : Cash taken\n"
"21/01/2021 09:53:39 : Transaction completed\n"
" 21/01/2021 09:53:41 : Session terminated")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.