re = /\[(parameters\('[^']+'\))\]/m
str = '[parameters(\'ECC_Shipment_Trigger_properties_pl_ecc_shipment_adls_sql_parameters_File_system\')]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end