$re = '/^\D.*?\D$/m';
$str = '1abc
abc
abc2
1abc2
a123b
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);