re = /\/\*[^*]*\*+([^\/*][^*]*\*+)*\//
str = '/*
* Some text here
*/
/**/ Some text here /**/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end