$re = '/^([^\/\n]*)(?:\/([^\/\n]+)\/)?([^\/\n]*)$/m';
$str = 'Fred Joseph /Smith/
/Smith/
Fred Joseph
/Smith/ Fred Joseph
Fred /Smith/ Joseph';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);