$re = '/^([^<]*)((<img>(\s*(\s*<\s*br\s*\/?\s*>\s*)*\s*))*)$/mi';
$str = 'sdfsdfsdf <img> <br> <Br><img> <img> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);