# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^\s=]+)=(?|\"([^\"]*)\"|(\S+))"
test_str = ("date=2019-05-10 time=11:50:48 logid=\"0001000014\" type=\"traffic\" subtype=\"local\" level=\"notice\" vd=\"vdom1\" eventtime=1557514248379911176 srcip=172.16.200.254 srcport=62024 srcintf=\"port11\" srcintfrole=\"undefined\" dstip=172.16.200.2 dstport=443 dstintf=\"vdom1\" dstintfrole=\"undefined\" sessionid=107478 proto=6 action=\"server-rst\" policyid=0 policytype=\"local-in-policy\" service=\"HTTPS\" dstcountry=\"Reserved\" srccountry=\"Reserved\" trandisp=\"noop\" app=\"Web Management(HTTPS)\" duration=5 sentbyte=1247 rcvdbyte=1719 sentpkt=5 rcvdpkt=6 appcat=\"unscanned\"\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.