re = /^(\+|-)?(?:90(?:(?:\.0{1,6})?)|(?:[0-9]|[1-8][0-9])(?:(?:\.[0-9]{1,6})?))$/
str = '50.000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end