$re = '/^([a-d]\).*?)+$/';
$str = 'a) option a b) option b c) option c d) option d"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);