// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:https:\/\/goo\.gl\/maps\/\w+)|(?:https:\/\/www\.google\.com\/maps.*\d)").unwrap();
let string = "https://goo.gl/maps/WwcXqVEA5vrEWFtAA
follow this link https://goo.gl/maps/rob6c2k27E4ZpiDd8
https://goo.gl/maps/efNxki1ek7RZ3CAFA need to check in google maps
https://www.google.com/maps/@-6.2964394,107.1813443,3a,75y,90t/data=!3m8!1e2!3m6!1sAF1QipNrLqMTMz-iqWjqvmedTHyQwGLhBE-Z0L46Z5mY!2e10!3e12!6shttps:%2F%2Flh5.googleusercontent.com%2Fp%2FAF1QipNrLqMTMz-iqWjqvmedTHyQwGLhBE-Z0L46Z5mY%3Dw203-h152-k-no!7i1000!8i750 is correct?
https://www.google.com/maps/place/Jl.+Raya+Rw.+Bangkong,+Sertajaya,+Kec.+Cikarang+Tim.,+Bekasi,+Jawa+Barat+17530/@-6.2971014,107.184237,19z/data=!3m1!4b1!4m5!3m4!1s0x2e699b50084e936d:0xc3f7ba2bef9eafc8!8m2!3d-6.2971641!4d107.1847831 how about this? 1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}