$re = '/^(https):\/\/(\w+)\.(\w+)\.(\w+)\/(\w+)/m';
$str = 'https://www.google.com/test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);