$re = '/^(?=.)(?:\d{1,3}(?:,\d{3})*|\d+)?(?:\.\d+)?$/m';
$str = '12345
.123
23,456,789.123
123.456.7
1234.
12345,
123.,
,123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);