import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<url>\\s*\n"
+ " (?>\n"
+ " (?>\n"
+ " (?><lastmod>\\s*(?<mod>[^<]+)\\s*</lastmod>)\n"
+ " |\n"
+ " (?><changefreq>\\s*(?<freq>\\w+)\\s*</changefreq>)\n"
+ " |\n"
+ " (?><priority>\\s*(?<prio>[01](?>\\.\\d{1,2})?)\\s*</priority>)\n"
+ " )\\s*\n"
+ " ){0,3}\\s*\n"
+ " <loc>\\s*\n"
+ " (?<uri>[^<]+)\\s*\n"
+ " </loc>\\s*\n"
+ " (?>\n"
+ " (?>\n"
+ " (?><lastmod>\\s*(?<mod>[^<]+)\\s*</lastmod>)\n"
+ " |\n"
+ " (?><changefreq>\\s*(?<freq>\\w+)\\s*</changefreq>)\n"
+ " |\n"
+ " (?><priority>\\s*(?<prio>[01](?>\\.\\d{1,2})?)\\s*</priority>)\n"
+ " )\\s*\n"
+ " ){0,3}\\s*\n"
+ "</url>";
final String string = "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
+ "<urlset xmlns=\"http://www.sitemaps.org/schemas/sitemap/0.9\">\n"
+ " <url>\n"
+ " <lastmod>2005-01-01</lastmod>\n"
+ " <changefreq>monthly</changefreq>\n"
+ " <priority>0.8</priority>\n"
+ " <loc>http://www.example.com/</loc>\n"
+ " </url>\n"
+ " <url>\n"
+ " <loc>http://www.example.com/catalog?item=12&desc=vacation_hawaii</loc>\n"
+ " <changefreq>weekly</changefreq>\n"
+ " </url>\n"
+ " <url>\n"
+ " <loc>http://www.example.com/catalog?item=73&desc=vacation_new_zealand</loc>\n"
+ " <lastmod>2004-12-23</lastmod>\n"
+ " <changefreq>weekly</changefreq>\n"
+ " </url>\n"
+ " <url>\n"
+ " <loc>http://www.example.com/catalog?item=74&desc=vacation_newfoundland</loc>\n"
+ " <lastmod>2004-12-23T18:00:15+00:00</lastmod>\n"
+ " <priority>0.3</priority>\n"
+ " </url>\n"
+ " <url>\n"
+ " <loc>http://www.example.com/catalog?item=83&desc=vacation_usa</loc>\n"
+ " <lastmod>2004-11-23</lastmod>\n"
+ " </url>\n"
+ "</urlset>";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}