$re = '/(\[[^\[\]\r\n]*\]):({.*?})(?: (?=\[)|$)/m';
$str = '[row1|col1]:{value:{{calculate}}<<report_1>>[Row2|col2];format:float;} [hiddenr0120a|c0012]:{format:float;}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);