re = /(?<= )(?=.{0,3}[A-Z])[A-Z\d]{2,4}\d{4,8}(?= )|(?<=\t).*?(?=\t)/m
str = 'XYZ INTERNATIONAL A1B101012 ABCD-XYZ-ABG089AB A000123456 UNI
________________________________________
XYZ INTERNATIONAL AB/PQRS/012345/ /ABC / PQRSTUVW ABCDEFGH CO ADDRESS CITY 1234 S RIDGELINE BLVD VA SOMECITY 12345 SOME BRANCH PKWY A0123456 N/A 0:00 CDT - 1:00 CDT
________________________________________
XYZ INTERNATIONAL AB/ABYX/271703/ /ABC / ABCDO47HBS ABCDEFG71 N/A N/A A0123456 N/A 0:00 CDT - 1:00 CDT
________________________________________
XYZ WORLDWIDE PTE. LTD. A1234597 N/A N/A N/A N/A A0123456 abcde-randomashb-12234568 0:00 CDT - 1:00 CDT
________________________________________
Convent Inc A123 4599 N/A N/A N/A N/A A0123456 abcde-randomhigh-00012345 0:00 CDT - 1:00 CDT
________________________________________
XYZ INTERNATIONAL B124565 N/A N/A N/A N/A A0123456 abcde-randomashb-12234568 0:00 CDT - 1:00 CDT
________________________________________
XYZ INC WA/OGGS/186815/ /ABC / ABCDEFGH PQRSTUVW N/A N/A A0123456 N/A 0:00 CDT - 1:00 CDT
________________________________________
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end