re = /<\s*(?:\/\s*)?(?:p|a|strong)\s*>/m
str = '<p > ¡Esto es una prueba! < /p > <p> <strong > Prueba 123 </strong> </p> <p> <strong> <a href="https://matricom.net"> MATRICOM < / a> </ strong> </p> <p> <strong > Todas las pruebas aquí ... </strong > < /p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end