const regex = /^(?<date>\d{4}-\d{2}-\d{2})(?<timestamp>[A-Z]\d{2}:\d{2}:\d{2}\.\d{3}-\d{4})\s+-\s+(?<loglevel>\w+)\s+(?<class>\[\w+\])\s+(?<message>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<date>\\d{4}-\\d{2}-\\d{2})(?<timestamp>[A-Z]\\d{2}:\\d{2}:\\d{2}\\.\\d{3}-\\d{4})\\s+-\\s+(?<loglevel>\\w+)\\s+(?<class>\\[\\w+\\])\\s+(?<message>.*)', 'gm')
const str = `2020-05-06T22:34:50.860-0700 - WARN [main] o.s.b.GenericTypeAwarePropertyDescriptor: Invalid JavaBean property 'pipeline' being accessed! Ambiguous write methods found next to actually used [public void com.theoaal.module.pipeline.mbean.DynamicPhaseExecutionConfigurationMBeanBuilder.setPipeline(com.theplatform.module.pipeline.DynamicPipeline)]: [public void com.theplatform.module.pipeline.mbean.PhaseExecutionConfigurationMBeanBuilder.setPipeline(com.theoaal.module.pipeline.Pipeline)]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}