# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{[^}]*\bname="(.*?)"[^}]*\}/$1/gm;t' <<< "{name=\"certbot.service\", state=\"failed\"}"