$re = '/\{[^}]*\bname="(.*?)"[^}]*\}/m';
$str = '{name="certbot.service", state="failed"}';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;