const regex = /(^.{33})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.{33})', 'gm')
const str = `=IFERROR(
MAX(
INDEX(
raw_wells_prod!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
),
INDEX(
raw_wells_inj!R1,
MATCH(
1,
raw_wells_prod!R,
0
)
)
),
0
) `;
const subst = `exprS = exprS & TrimRight("$1") & _`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);