$re = '/(?:name\=)([A-Za-z{}": \',&-=\\\\]+)$/sm';
$str = 'name=test
test=test
name={"first": \'John\', \'Last\': \'Doe\'}
name=first=John&last=Doe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);