re = /(\d+)?(?(1) )(foo)(?(1)| (\d+)\b(?! foo))/m
str = '1234 foo
foo 1234
1234 foo 1234
foo 1234 foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end