re = /(?:is|are)? called [a]?[an]?[its]?\b ?([^.|,|;]+)/m
str = 'If we can prove a statement true, then that statement is called a proposition.
In studying abstract mathematics, we take what is called an axiomatic approach; that is, we take a collection of objects S and assume some rules about their structure. These rules are called axioms.
Sometimes instead of proving a theorem or proposition all at once, we break the proof down into modules; that is, we prove several supporting propositions, which are called lemmas, and use the results of these propositions to prove the main result'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end