$re = '/\A\s*(?>[^\s:]+:(?(1)\1|(\S+))\s*)+\z/';
$str = ' 2:K1663
3:K1675
4:K1663
5:K1663
6:K1663
7:K1663
8:K1675
13:K1675
14:K1675';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);