using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=helloworld\/\.@==).*?(?![^\s?])";
string input = @" https://example.com/helloworld/.@==imhere or https://example.com/helloworld/.@==imnothere?param1=value1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}