$re = '/Date\sOf\sIncident\:\s*(?<myDate>[\S]+)\s*.*?Time\sof\sIncident\:\s*(?<myHr>\d{2})(?<myMn>\d{2})/';
$str = 'sdsd sjjde sdakl Date Of Incident: 12/02/2015 12:00:00 AM, Time of Incident: 0150 sdfksjf ksjhfdks jshfd ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);