re = /^(?:(?!##|\*\*).)*\*\*.*##/m
str = '**Lorem ipsum dolor sit amet##\';
test****#**##
##**Lorem ipsum dolor sit amet##
##**##**
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end