package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).* tag:(.+)( |$)`)
var str = `?q=user:bob tag:horror tag:comedy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}