re = /(?!#hashtag|#DoNotRemoveThis)(#[\w-]+)/
str = 'Any #hashtag in the middle of the string should NOT be removed regardless of what it is, for example #DoNotRemoveThis #KeepThisHashtag and any hashtag at the end of the string should be removed UNLESS it matches the exeptions in the regex. #deletethis #DoNotRemoveThis #thismustgoaway'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result