#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+(?:\.\d+)*)\s+([\s\S]*?)(?=^\d+(?:\.\d+)*)|^(\d+(?:\.\d+)*)\s+([\s\S]*)"
Local $sString = "I.S. EN 60601-1:2006&A1:2013&AC:2014&A12:2014" & @CRLF & _
"" & @CRLF & _
"60601-1 © IEC:2005 " & @CRLF & _
"60601-1 © IEC:2005" & @CRLF & _
"" & @CRLF & _
"– 337 – " & @CRLF & _
"– 169 –" & @CRLF & _
"" & @CRLF & _
"12.4.5.4 Other ME EQUIPMENT producing diagnostic or therapeutic radiation " & @CRLF & _
"When applicable, the MANUFACTURER shall address in the RISK MANAGEMENT PROCESS the " & @CRLF & _
"RISKS associated with ME EQUIPMENT producing diagnostic or therapeutic radiation other than " & @CRLF & _
"for diagnostic X-rays and radiotherapy (see 12.4.5.2 and 12.4.5.3). " & @CRLF & _
"" & @CRLF & _
"Compliance is checked by inspection of the RISK MANAGEMENT FILE." & @CRLF & _
"" & @CRLF & _
"12.4.6 Diagnostic or therapeutic acoustic pressure " & @CRLF & _
"When applicable, the MANUFACTURER shall address in the RISK MANAGEMENT PROCESS the " & @CRLF & _
"RISKS associated with diagnostic or therapeutic acoustic pressure. " & @CRLF & _
"" & @CRLF & _
"Compliance is checked by inspection of the RISK MANAGEMENT FILE." & @CRLF & _
"" & @CRLF & _
"13 * HAZARDOUS SITUATIONS and fault conditions" & @CRLF & _
"" & @CRLF & _
"13.1 Specific HAZARDOUS SITUATIONS" & @CRLF & _
"" & @CRLF & _
"* General " & @CRLF & _
"" & @CRLF & _
"13.1.1 " & @CRLF & _
"When applying the SINGLE FAULT CONDITIONS as described in 4.7 and listed in 13.2, one at a " & @CRLF & _
"time, none of the HAZARDOUS SITUATIONS in 13.1.2 to 13.1.4 (inclusive) shall occur in the " & @CRLF & _
"ME EQUIPMENT." & @CRLF & _
"" & @CRLF & _
"The failure of any one component at a time, which could result in a HAZARDOUS SITUATION, is " & @CRLF & _
"described in 4.7. " & @CRLF & _
"" & @CRLF & _
"* Emissions, deformation of ENCLOSURE or exceeding maximum temperature " & @CRLF & _
"" & @CRLF & _
"13.1.2 " & @CRLF & _
"The following HAZARDOUS SITUATIONS shall not occur: " & @CRLF & _
"– emission of flames, molten metal, poisonous or ignitable substance in hazardous " & @CRLF & _
"" & @CRLF & _
"quantities; " & @CRLF & _
"" & @CRLF & _
"– deformation of ENCLOSURES to such an extent that compliance with 15.3.1 is impaired; " & @CRLF & _
"– " & @CRLF & _
"" & @CRLF & _
"temperatures of APPLIED PARTS exceeding the allowed values identified in Table 24 when " & @CRLF & _
"measured as described in 11.1.3; " & @CRLF & _
"temperatures of ME EQUIPMENT parts that are not APPLIED PARTS but are likely to be " & @CRLF & _
"touched, exceeding the allowable values in Table 23 when measured and adjusted as " & @CRLF & _
"described in 11.1.3; " & @CRLF & _
"" & @CRLF & _
"– " & @CRLF & _
"" & @CRLF & _
"– exceeding the allowable values for “other components and materials” identified in Table 22 " & @CRLF & _
"times 1,5 minus 12,5 °C. Limits for windings are found in Table 26, Table 27 and Table 31. " & @CRLF & _
"In all other cases, the allowable values of Table 22 apply. " & @CRLF & _
"" & @CRLF & _
"Temperatures shall be measured using the method described in 11.1.3. " & @CRLF & _
"" & @CRLF & _
"The SINGLE FAULT CONDITIONS in 4.7, 8.1 b), 8.7.2 and 13.2.2, with regard to the emission of " & @CRLF & _
"flames, molten metal or ignitable substances, shall not be applied to parts and components " & @CRLF & _
"where: " & @CRLF & _
"– The construction or the supply circuit limits the power dissipation in SINGLE FAULT " & @CRLF & _
"" & @CRLF & _
"CONDITION to less than 15 W or the energy dissipation to less than 900 J. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")