$re = '/(?P<error>(?<=-.).*?(?=\]))/m';
$str = '[app.py:1891 - log_exception] Exception on /batch_request [POST]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);