package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^\s*(([<>=][=]{0,1})|(<>))\s*\d+(\.\d+)?$)|^\s*$`)
var str = `12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}