package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.\d+$`)
var str = `.001
.002
.004
.spm
.0009`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}